Unwanted opening of the example file at start up on a 64-bit install

Hi there,

I've disabled the opening of the example file at JalView 2.8 startup on a 32-bit XP computer running JRE 1.5.0.70.
But it seems that a 64-bit Win7 computer running JRE 1.6.0_20-b02 can't just write down that information.
As I thought it may be related to the security software, I uninstalled it, only to realize this did not change anything.
Any suggestion?
Could it be a feature (not to say a bug) of the 64-bit version of JalView 2.8?

Thank you very much for your attention, and possibly for your help!
Have a nice day,

Antoine

Hello Antoine,

I've disabled the opening of the example file at JalView 2.8 startup on
a 32-bit XP computer running JRE 1.5.0.70.
But it seems that a 64-bit Win7 computer running JRE 1.6.0_20-b02 can't
just write down that information.
As I thought it may be related to the security software, I uninstalled
it, only to realize this did not change anything.
Any suggestion?
Could it be a feature (not to say a bug) of the 64-bit version of
JalView 2.8?

I've lodged a bug here:
http://issues.jalview.org/browse/JAL-1221

I've not encountered any problems with storing the jalview properties file on w7/64bit - but its entirely posible that there is a bug.

Could you follow the instructions in the FAQ and send me the console log for windows 7:
http://www.jalview.org/faq#bug

Please let me know which type of jalview install you are using (InstallAnywhere or webstart), and send me the log files for the following operations:
1. start jalview and open the jalview console window, open the preferences dialog box and check that the 'open file' tickbox is unchecked, then hit OK on the preferences, and close jalview.
2. start jalview again, click through all the dialogs that pop up, wait for the example file to finish loading, then cut and paste the console log.

Note: if the jalview user properties really aren't being saved properly, then when you do 2 you'll find that the Jalview console window isn't opened by default on start up. In that case, follow the instructions on the FAQ entry to open the system java console via the java control panel.

Jim.
ps. you don't have to send the log files to me - if you register over at issues.jalview.org then you can just paste or attach the log files to the bug report at http://issues.jalview.org/browse/JAL-1221

···

On 19/12/2012 09:30, Antoine Maillard wrote:

Hi Antoine.

I have a suspicion that the Jalview desktop being launched by your 64bit machine is using a bookmark to a one of the increased memory allocation links from the http://www.jalview.org/jvmmemoryparams.html page.

It turns out that a side effect of using these links is that an old example file is *always* opened, regardless of your preferences. I’ll be fixing that shortly (it’s linked to from http://issues.jalview.org/browse/JAL-1221 ) but until then, the only workaround is to edit the JNLP file to remove the ‘-open’ and ‘http://www.jalview.org/examples/exampleFile.jar’ argument tags from the JNLP file using notepad or something similar.

Jim.

···

On 19/12/2012 13:47, Jim Procter wrote:

Hello Antoine,

On 19/12/2012 09:30, Antoine Maillard wrote:

I've disabled the opening of the example file at JalView 2.8 startup on
a 32-bit XP computer running JRE 1.5.0.70.
But it seems that a 64-bit Win7 computer running JRE 1.6.0_20-b02 can't
just write down that information.
As I thought it may be related to the security software, I uninstalled
it, only to realize this did not change anything.
Any suggestion?
Could it be a feature (not to say a bug) of the 64-bit version of
JalView 2.8?

I've lodged a bug here:
http://issues.jalview.org/browse/JAL-1221

I've not encountered any problems with storing the jalview properties
file on w7/64bit - but its entirely posible that there is a bug.

Could you follow the instructions in the FAQ and send me the console log
for windows 7:
http://www.jalview.org/faq#bug

Please let me know which type of jalview install you are using
(InstallAnywhere or webstart), and send me the log files for the
following operations:
1. start jalview and open the jalview console window, open the
preferences dialog box and check that the 'open file' tickbox is
unchecked, then hit OK on the preferences, and close jalview.
2. start jalview again, click through all the dialogs that pop up, wait
for the example file to finish loading, then cut and paste the console log.

Note: if the jalview user properties really aren't being saved properly,
then when you do 2 you'll find that the Jalview console window isn't
opened by default on start up. In that case, follow the instructions on
the FAQ entry to open the system java console via the java control panel.

Jim.
ps. you don't have to send the log files to me - if you register over at
issues.jalview.org then you can just paste or attach the log files to
the bug report at http://issues.jalview.org/browse/JAL-1221

_______________________________________________
Jalview-discuss mailing list
Jalview-discuss@jalview.org

http://www.compbio.dundee.ac.uk/mailman/listinfo/jalview-discuss