-props argument in JNLP

I have configured a JNLP by altering the following section (codebase is localhost/Jalview/webstart):

-props http://localhost/Jalview/webstart/local.properties

The properties are not read. Jalview prompts for google tracking and then loads the example file from jalview.org despite the properties indicating not to load an example file and to take it from localhost. Obviously I can’t open the Java console until the application has started so can’t see what is going on.

Any clues? Are null values allowed in the property fields?

local.properties contains the following (as does my .jalview_properties file)

Kristen Eisenberg
Billige Flüge
Marketing GmbH
Emanuelstr. 3,
10317 Berlin
Deutschland
Telefon: +49 (33)
5310967
Email:
utebachmeier at
gmail.com
Site:
http://flug.airego.de - Billige Flüge vergleichen

Hello Kristen. I'm sorry to hear your having some problems here.

I have configured a JNLP by altering the following section (codebase is localhost/Jalview/webstart):

<application-desc main-class="jalview.bin.Jalview">
<argument>-props</argument>
<argument>http://localhost/Jalview/webstart/local.properties</argument>
</application-desc>

The properties are not read. Jalview prompts for google tracking and then loads the example file from jalview.org despite the properties indicating not to load an example file and to take it from localhost. Obviously I can't open the Java console until the application has started so can't see what is going on.

You can enable the standard java console - which will start up before any application is launched - by configuring the appropriate option under the 'advanced' tab of your machine's java configuration console (in your system console/settings or you can sometimes access it by executing javaws from the command line with no arguments). However, the jalview java console should also start at the same time as Jalview if you have it enabled in your properties file.

Any clues? Are null values allowed in the property fields?

depends on the property fields - and for that I'd need to see the file. However, it sounds like you may have a slightly different problem. In your custom JNLP, do you have an attribute like 'href="http://www.jalview.org/webstart/jalview.jnlp"' on the jnlp tag ? If you do, then javaws will always read the jnlp at that location rather than your custom one.

If the above isn't the case, then could you please send me both your custom jnlp and properties file ? (I presume your using jalview version 2.7 here, since the -props argument doesn't take URLs in earlier versions!). Also, if you simply want to load a file on startup, you might consider just passing that file's URL directly as a command line argument... then, Jalview will load that and ignore any default startup file settings.

Jim.

···

On 21/10/2011 20:56, Kristen Eisenberg wrote: