png images

this is my problem:

I used a jalview batch to incorporate jalview into an alignment program.
I put some parameters as -colour, and -png to safe the resulting file as image.
All is ok except in the png files there is a superimposition of some letters and numbers at the beginning of the images, as if the images were not large enough to display correctly.
I can’t find a way to set up some parameters to try to have images with different dimensions.
To save in svg doesn’t change the result.

If I use jalview desktop and I save the box as png image all is ok, not superimposition, but i can’t use it because I need to include jalview into my code.

Any suggestion to set some parameters ?

I attached an image as example. As you can see numbers in the left side are not display correctly.




Hi Alessandra.

From your image, it looks like the ID width margin is not being set automatically. There was a feature introduced to set the margin automatically, or keep it as a fixed width for flipbook style alignment browsing (where you don’t want the margin to move around).

We’ll take a look at it and get back to you. Could you let me know which version of Jalview you’re running in your code ?



On 09/06/2015 09:24, Alessandra Gastaldello wrote:

Hi again, Alessandra.
Append the following lines to your jalview properties file:


(also make sure there’s a return or blank line at the end of the properties file).

This will tell jalview to automatically compute the margin to fit in all sequence IDs, and also right align them so that the start/end numbering appear in the same place each time.



On 09/06/2015 09:53, Jim Procter wrote:

On 09/06/2015 09:24, Alessandra Gastaldello wrote:

Ah - no problem !

Your default jalview properties file lives in ~/.jalview_properties … since you aren’t using the ‘props’ argument to provide a custom properties file, jalview will use that one.

In your case, you can either append the lines to that file, or add the settings via the GUI. For the ID width problem, simply open your Jalview preferences, select the ‘Output’ tab, and then make sure the ‘Automatically fit ID width’ checkbox is checked. Right align is enabled from the ‘Visual’ tab. Remember to press OK and close Jalview to update your properties file afterwards.

For reproducibility’s sake, once you’ve made the changes, I’d recommend you copy your default file to somewhere where your script lives, and add a -props argument to include it. That means your output will stay the same even if you change your jalview preferences in the future.

Let me know how you get on !


On 09/06/2015 11:46, Alessandra Gastaldello wrote:

Hi Alessandra. I’m glad you’ve got this working !

Regarding the SVG output - there’s nothing in the current version of Jalview that you can change to modify the borders on the SVG file. We’re working on a more flexible system for v2.9 - which is already in use on the Jpred4 site (, and I’ll add a feature request about allowing borders on the output. However, SVG output is also very easy to manipulate, since it is simple XML, so it might be easier to simply add in some additional commands to create a white border around the alignment.



On 10/06/2015 11:04, Alessandra Gastaldello wrote: