Launching problem

I can not run the Jalview on my laptop. I uninstalled it, downloaded and reinstalled it, but still the same problem. Anyone have a solution?

Hi Leila,

Hopefully we can help you get Jalview up and running on your laptop!
We’ll need a bit more information though, can you let us know if it’s a Windows laptop, or a mac or something else?

We also have some installation videos, showing how an installation is meant to happen, linked from the Jalview download page.
Follow the link on the right that reads “Install on …” for your computer.
You should be able to see a video near the top of the next (“Installing on …”) page that shows how the installer download should work for your platform.
If this isn’t working, can you say what stage you get to, or if the installer doesn’t start at all?

Best wishes,

Ben

Dear Ben
Thanks for the fast feedback. I’m using a Windows laptop. To see if I am doing something wrong, I watched the video. I didn’t find something different. This is the first time I have experienced this with Jalview since I have been using it for years. Once I run the software, it starts running, and only appears in the toolbar, but when I click I cannot open it.
Best,
Leila

Hi Leila,

This is a new one, but I have a couple of ideas!

Do you remember what version of Jalview you uninstalled before (I’m wondering if the old installation started with “2.11” or was it an older version)?

May I confirm with you that the installation all seems to go to plan (like the video on the website) and you can then find the Jalview icon and launch it, and the icon appears on the taskbar, but no desktop window appears? Do you have a line or dash under the taskbar icon indicating that Jalview is running (somewhere!)?

Best wishes,

Ben

Hi Ben,

The one I uninstalled was 2.11, and now I have the same version, which is the last version I know of. I followed the installation video and the installation was successful. I only had one difference: I didn’t get the error from Windows Defender and I skipped straight to the installation step. This is exactly what happened: The software was launched, then disappeared. There is a dash under the icon on the toolbar.

Best,
Leila

Hi Leila,

The dash under the icon indicates that Jalview is running, so it must be hiding somewhere! I suspect off-screen down to configuration that has been saved from the previous version.

The easiest way to start with new settings is to rename the old settings file (this is .jalview_properties – note the . at the start of the filename) in your user home folder. If you can find that and rename it to (e.g.) .jalview_properties_old (do that when Jalview is not running) and then try and launch Jalview, there’s a good chance that it will now appear on screen.

I’ve made a screen capture showing the steps involved to rename the .jalview_properties file (attached below). I’m not sure if the Show Hidden Files step is strictly needed but just in case I’ve done that…
Also, apologies that the mouse cursor looks tiny (recorded on a 4k screen).

You may need to resize the Jalview window after it opens if you have a high resolution screen too.

Finally, renaming the .jalview_properties file will remove any other Preferences changes that you’ve made. If you want to keep those, instead of renaming the .jalview_properties file you could open it in a Text Editor and delete the lines that start with

SCREENGEOMETRY_HEIGHT=
SCREENGEOMETRY_WIDTH=
SCREEN_HEIGHT=
SCREEN_WIDTH=
SCREEN_X=
SCREEN_Y=

so that the defaults will be applied at the next launch.

Let us know how you get on.

Ben