jalview in linux -- problems

Hi Zhao - the -jar flag only works for the desktop application (created
with 'ant makedist').

For the jalview applet, you need to launch it via an html page opened
in a browser or via the appletviewer.

Which version are you interested in running ? the Jalview desktop
(v2.8.0b1) is already available in debian unstable. I'm not sure when
2.8.1 will make it in there - it depends on one of our friendly
packagers (or me) having some time to spare!

Jim

···

On Sat Jun 21 10:40:00 2014, Zhao lina wrote:

Hi Jim,

java 1.1.8 jdk, is this one: http://archive.debian.net/en/potato/jdk1.1

Thanks,

On 21/06/2014 17:06, Zhao lina wrote:

Hi Jim,

Recent couple of days I have been trying build the jalview on linux box
(debian).

Here I attach the build.xml which I modified a little due to original
not work. Meanwhile, I put the plugin.jar in the appletlib and also lib.

Everything go fine till `ant makeApplet`, after generation the
jalviewApplet.jar

then when I tried to run

:/scratch/lina/java_projects/jalviewX$ java -jar jalviewApplet.jar
Exception in thread "main" java.lang.NoClassDefFoundError:
netscape/javascript/JSObject
Caused by: java.lang.ClassNotFoundException: netscape.javascript.JSObject
     at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
     at java.security.AccessController.doPrivileged(Native Method)
     at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class: jalview.bin.JalviewLite. Program will exit.

I don't know much about ant project, but recent couple of days I have
tried to know some bit, I think the problem raised due to the run time
classpath problem, but not sure.

It is going to be great to have your suggestions, best regards,

P.S. the plugin.jar was get from the

$ ls /usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/plugin.jar

The University of Dundee is a registered Scottish Charity, No: SC015096

You're right - I had thought that the BioLinux package for Jalview 2.8.1
had already made it to debian, too. It seems not. You can get Jalview
2.8.0b1 via
https://launchpad.net/~tbooth/+archive/ppa1

Can you give me a more detail about "launch it via an html page".

Currently I am trying the

$ appletviewer jalviewApplet.jar

I just checked on a not-quite-up-to-date debian box, and I could do:

wget http://www.jalview.org/source/jalview_2_8_1.tar.gz
tar -zxf jalview_2_8_1.tar.gz
cd jalview
ant pubapplet # works fine up until the signjar step - which fails on my
older Oracle JDK
appletviewer -J-Djava.ext.dirs=/usr/lib/jvm/java-7-oracle/jre/lib
dist/examples/applets.html

As you can see, I was using the non-free oracle jdk. You many need a
different path for openjdk (and probably need to use 1.7, not 1.8!).

However, are you really wanting to launch the applet ??? If you are
actually after the desktop (which is what apt-get install jalview gives
you) then all you need to do is:

ant makedist
java -Djava.ext.dirs=lib -jar dist/jalview.jar

let me know how you get on ...
Jim

The University of Dundee is a registered Scottish Charity, No: SC015096

···

On 21/06/2014 13:39, Zhao lina wrote: