editing and autoscrolling

Hi Jim,

Thanks for your response. As described below, it feels as if
there is a memory issue when autoscrolling kicks in. Always happens
after I have done quite a bit of editing. My RAM is not fully used,
then, but maybe what has been allocated to Jalview is; I have changed
values in the lax file as I saw advised on the web site

# -----------------------------------------
# Initial heap size for Jalview


# -------------------------------------
# Maximum heap size for Jalview


Maybe I can go up
further with my 16GB of ram and intel i7 quad core processor with HD
Graphics 4000 graphics?

Hello Rob.

Perhaps we could Skype about your email ? I think there are a couple
of different things going in regarding your automatic scrolling issue.
I'm also interested in exploring different alignment tools for RNA and
would value your advice about what we could incorporate in Jalview.


With respect to alignment tools for RNA which ones are you considering?
My experience is not so good with alignment programs I have used
(because they seem more geared up to protein-coding sequences) but I
probably have missed new developments. Anyway, lack of trustful
alignments made me use JalView a lot ;-).

For example, a problem with a program like alifold is that it needs
first an excellent alignment to begin with (say made with Jalview) and
then it only displays stems that are formed by the consensus. Any
compensatory base changes if these are not subtle and sometimes mean a
longer or shorter stem, for example, seem ignored, which means loss of
a lot of information.

I still rust my eyes more than output of such programs.

Best regards,



Begin forwarded message:

Date: Mon, 30 Mar 2015 13:03:46 +0100
From: rob van nues <rob.van-nues@ed.ac.uk>
To: "Mungo Carstairs (Staff)" <g.m.carstairs@dundee.ac.uk>
Subject: Re: [Jalview-discuss] editing and autoscrolling

Hi Mungo,

Thank you so much for answering me in so much detail. I should have
RTFM and discovering the CONTROL+DRAG is a life-saver. Below, more
about my experience as a user and how I think stuff might be
more intuitive. Saying that, my intuition might quite abnormal. One has
to test this on a group of users without too much habits/exposure to
your program.

One thing you definitely want to consider is, as said as
well below, to add a shortcut to the HELP-menu that gives access to the
KEY-strokes help-page (and include in this the SHIFT+DRAG and
CONTROL+DRAG functions), also when a user is off-line.

Cheers, and keep up the good work.

Thanks again,


On Mon, 30 Mar 2015 07:49:15 +0000 "Mungo Carstairs (Staff)" <g.m.carstairs@dundee.ac.uk> wrote:

Hello Dr van Nues,

Let me try to address some of your issues...

1) editing: the context menu to Edit an alignment is indeed quite
hidden, but is only meant as a 'last resort' for editing residues. It
sounds like you are wanting to edit/remove gaps. This can be done
using mouse and/or cursor operations much more easily. Please take a
look at the help for Editing Alignments, in the tool or online at

Thank you for pointing out the different MODEs to me, I had completely
forgotten about them. Accidentally I discovered that SHIFT+(then
select+) DRAG is very useful......;-)...and also the CONTROL+DRAG, for
moving a bunch of cells. Still without RTFM I would have never found
this and it took me bit to see how this works. Below my step-wise
experience of these userface elements. Maybe room for some improvement
or changes that would make it a bit more consistent/intuitive??

After trying the CURSOR mode, I realised why I am always
ending up with the 'last resort' context editing mode: I mostly want to
make many changes in one go, i.e. select a whole bunch of different
but fairly similar sequences and move or edit them.

Say, in an alignment of many similar sequences that have a section
GAAAGGGGTT---------TCCCCA and I want to change this to
GAAAG--------GGGTTTCC------CCA, I select all identical bits in this set
(GGGTTTCC---------TCC) and can edit this (to --------GGGTTTCC-----) in
one go. This saves me a lot of time.

In CURSOR mode this has to be done one by one, which brings me back to
square one as I do not see how to select multiple lines in this mode. I
tried to use Q and M but I did not get any selection I could work on as
a whole. Thus, the expected way around would be if q and m would allow
to get a selection in CURSOR mode as I understood but here on linux
(xfce, slackware64-current) I sometimes can get a selection with q
(first select a cell, then press q and select the same cell again and
drag. During dragging I SOMETIMES get a selection of multiple rows and
columns, and SOMETIMES only one column of cells (i.e. not in two
dimensions, only top-down). But this selection cannot be moved with
SHIFT+drag or using the space bar. With this selection I can only do
context-editing (but for that I do not need to be in CURSOR mode; in
NORMAL mode selecting a group of cells is very straightforward).

I also tried to get around the one-by-one move by selecting
in NORMAL mode a short (not complete) column of nucleotides in a set of
sequences and THEN go to CURSOR mode but that did not work. (For
clarity: I am not shifting a whole column, that can be selected in the
top line and gives that red square, it is a subsection of the alignment
that needed shifting). SHIFT+DRAG works only on one line, not on a
selection of multiple lines (and eventually I discovered CONTROL+DRAG
to do this; but this seems a bit counter-intuitive as one is working on
a selection, not the whole sequence; but this would also be a matter of
changing habits at my side).

A more intuitive way forward would be if one could select a bunch of
cells, hit F2, and do SPACE to move them or, in NORMAL mode, then press
SHIFT+DRAG (or CONTROL+DRAG) to move them all. According to the manual
this only works after selection whole sequences, which, for me is new,
but alas, now I know this, this will save me loads of time! THANK YOU.

Still, it would be very helpful to add a shortcut to a built-in
KEYstrokes-help-page in a tab of the HELP-menu key and maybe implement
an extra key that works on a selection (SHIFT+E??) which would bring up
the dialog box as when one has right-clicked on a selection.

You see, I am doing only 'last resort aligning' because
some of the conserved elements in non-coding RNAs can only be picked up
by eye; too much variation -in length and sequence- in between these.

2) double-right-click behaviour - I am puzzled by this, as I can't
reproduce it. Can you describe in any more detail how/when this

For 'last resort' context editing, when you accidentally double
click on a cell you get a white flashing speckle in this cell and you
cannot do anything from that point onwards: one has to click outside the
selected cells and start over again.

3) behaviour of scrolling: there are some known issues with this, but
'turning on automatic scrolling' doesn't seem to have been reported

It feels as if I hit a memory problem when this happens. Only after
many steps and a huge scroll, followed by a context-edit, automatic
scrolling kicks in when I make another selection after that.

You may find that working in cursor mode (using Q and M to
mark regions) lets you avoid this issue. If it continues to be a
problem please describe a reproducible example if possible, and we'll
look into it.

The Q and M (either shift+q/m or just q/m), neither does anything
useful for me, (see above) otherwise this would be a nice way around it.

4) editing at end of sequences - I'll get back to you on that...

Select a row of the very last cells of an alignment (i.e. without a
space-cell defined/placed after either of them), get the context-edit
menu up and try to add --------------- or a sequence to these ends
and only the first line of the selection will be changed, not the rest.
When you want to add a space within the selection it works OK (all
lines get changed). It is the adding that does not work. I need to
'fill-in' lines with space-symbols in order to be able to edit whole
columns in one go. If the column hits a 'blank', editing stops at that
line and does not continue in the lines further down that have

5) you are correct that there is no Preference setting to turn off
automatic scrolling on startup; I can raise a feature request for
this. Note that if you save and later reload a Jalview project, the
state of this option is preserved. But this setting relates to
following a mouseover of a linked alignment or structure, which
doesn't sound quite like your problem if you are working in a single

Best regards,

Mungo Carstairs
Jalview Computational Scientist
The Barton Group
Division of Computational Biology
College of Life Sciences
University of Dundee, Dundee, Scotland, UK.

From: jalview-discuss-bounces@jalview.org
<jalview-discuss-bounces@jalview.org> on behalf of rob van nues
<rob.van-nues@ed.ac.uk> Sent: 27 March 2015 11:54 To:
jalview-discuss@jalview.org Subject: [Jalview-discuss] editing and

Hi, I have been using JalView for a couple of years now, mainly for
manual correction of computer generated alignments of quite divergent
RNAs (in length and sequence) that, however, share particular
conserved elements not picked up by the alignment programs.

I work mainly offline (in the train etc) and always install the
program locally.

For including spacing on particular sequences I use the editing
function but this function is quite hidden. After right-click, it
takes going down two drop-down menus to select this option and if one
need to do this a lot this becomes quite tiresome. Is there a way of
associating a key-stroke with this function? Especially as, when
accidentally right-clicking twice, another function is activated (I
see a tiny dot in the selected cell) but can't do anything with it.

Further, once I have been scrolling to select a large stretch of
sequence horizontally or through a large set of sequences vertically
for editing (mainly for introducing spaces) suddenly automatic
scrolling is activated which makes subsequent selection of a stretch
of nucleotides impossible (one has lost control now). Turning off
automatic scrollling does not help here and I have to close the
program and restart it again.

Further, editing at ends of a group of lines seems sometimes
impossible (i.e. trying to extend a line can only done one-by-one
when a whole group could be edited in one go.

I do not know whether this has to do with the OpenJDK version
1.7.0_75 I am using on slackware linux but it is quite annoying and
inconsistent user interface behaviour. It would be very helpful if
local installs could be customised so that, say automatic scrolling is
always turned off from the start, or where one can define some
key-bindings to frequently used functions.

If anyone has any tips to get this done in the meantime I will be very
grateful. It's a great program to use for this, but one could speed up
the work-flow immensely with such customisation.

Best regards

Dr. R.W. van Nues


The University of Edinburgh
CH Waddington Building
Max Born Crescent
Edinburgh EH9 3BF

Telephone +44 (0)131 651 9018

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

Jalview-discuss mailing list

The University of Dundee is a registered Scottish Charity, No:

Dr. R.W. van Nues


The University of Edinburgh
CH Waddington Building
Max Born Crescent
Edinburgh EH9 3BF

Telephone +44 (0)131 651 9018

Dr. R.W. van Nues


The University of Edinburgh
CH Waddington Building
Max Born Crescent
Edinburgh EH9 3BF

Telephone +44 (0)131 651 9018

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.