In the jalview programme, the web service, alignment, is greyed out and not clickable.

I have tried clearing and clicking on show java consoles under tools, and refresh services under web services, but no improvement.
Specifically, when I click refresh services, the blue bar below moves and doesn’t stop (it doesn’t complete). I also tried removing windows firewall, and allowing java to connect through the firewall, but no improvement.

I have attached below the information from the java console.

Jalview Version:
Jalview Installation: Source git-commit:63363f5d65 [releases/Release_2_11_3_Branch]
Build Date: 16:58:04 30 November 2023
Java version: 1.8.0_372
Java platform: amd64 Windows 10 10.0
Install4j version: 10.0.5
Install4j template version:
Launcher version: 1.8.3-1.3.1_JVL
LookAndFeel: FlatLaf Light (com.formdev.flatlaf.FlatLightLaf)
Channel: release
INFO - Cannot set Taskbar
ERROR - java/awt/Taskbar
INFO - Setting custom proxy settings
INFO - Successfully completed commands

Please let us know the solution at your earliest convenience.

Hi @rsiv94,

As I think you’ve guessed it looks very much like an internet connection problem, and you’ve tried some of the things I would suggest. Here are some more suggestions:

  1. Do you need to set an HTTP proxy from your location? If so you can set proxy settings for Jalview by going to Tools → Preferences and then going to the Connections tab. If the proxy requires username and password these can be entered here (the password will not be stored on disk, so Jalview will prompt for the password if needed when it starts up again).
  2. Check that the JABAWS server connection is set correctly and validated:
    i) Open the Java Console (Tools → Java Console), then select DEBUG in the bottom left of the Java Console window.
    ii) Select Tools → Preferences and in the Preferences window choose the Web Services tab (where you find the “Refresh Services” button). There should be a green rectangle next to the in the Web Services tab. If it’s orange or red then there is a problem of some kind.
    iii) You can validate the JABAWS connection by selecting, clicking on Edit Service URL and then OK and then when it asks “Validate JabaWS Server?” click on Yes. This takes up to about half a minute before there is some output in the Java Console.

If this doesn’t improve anything, could you copy and paste the output in the Java Console from (2)(iii)?

(Also, can you get to the webpage at in a web browser?)

Thanks, Ben