Gap symbol in alignment output window

Dear Jalview staff,

In our lab we are great fans of your tool, and we have recently upgraded from an old Jalview version to the newest (v. 2.8.2). Unfortunately, though, we found out a new feature which is not ideal for our workflow:

In the old version, when we selected some sequences from an alignment and chose the option “Output to textbox…” the gap symbol used in the “Alignment output” window was matching the symbol selected in the preferences. Therefore, if we chose to display the gaps as dots, we had dots also in the output window. With the new version the gap symbol used in the output window seems to depend only on the format chosen, and not on the symbol selected in the preferences.

On the other hand, if we save the alignment with the “Save as…” button, the gap symbol used is the same one we chose in the “Preferences”.

Here is our question: is there still a way to keep the preferred gap symbol also in the output window? Unfortunately, dashes are not Excel-friendly and we have several VBA macros to run on the selected sequences.

Thank you for your time,
Linda

Hello Linda,

Thanks for your enquiry. I have tried to reproduce this behaviour in Jalview 2.8.2 but for me it behaves as it should.

An alignment with dot for gaps is output (to either textbox or file) with dots.

The gap character used is fixed for an alignment at the point where it is created (changing to dot in Preferences won’t affect any open alignments).

If the problem persists, could you please describe the exact steps you are taking, and if possible send your Jalview preferences file?

(This is .jalview_properties which should be in your user home directory.)

Thanks,

Mungo

The University of Dundee is a registered Scottish Charity, No: SC015096

···

Mungo Carstairs
Jalview Computational Scientist
The Barton Group
Division of Computational Biology
School of Life Sciences
University of Dundee, Dundee, Scotland, UK.
www.jalview.org
www.compbio.dundee.ac.uk


From: jalview-discuss-bounces@jalview.org jalview-discuss-bounces@jalview.org on behalf of Linda Kazandjian lindak84@gmail.com
Sent: 01 September 2015 12:10
To: jalview-discuss@jalview.org
Subject: [Jalview-discuss] Gap symbol in alignment output window

Dear Jalview staff,

In our lab we are great fans of your tool, and we have recently upgraded from an old Jalview version to the newest (v. 2.8.2). Unfortunately, though, we found out a new feature which is not ideal for our workflow:

In the old version, when we selected some sequences from an alignment and chose the option “Output to textbox…” the gap symbol used in the “Alignment output” window was matching the symbol selected in the preferences. Therefore, if we chose to display the gaps as dots, we had dots also in the output window. With the new version the gap symbol used in the output window seems to depend only on the format chosen, and not on the symbol selected in the preferences.

On the other hand, if we save the alignment with the “Save as…” button, the gap symbol used is the same one we chose in the “Preferences”.

Here is our question: is there still a way to keep the preferred gap symbol also in the output window? Unfortunately, dashes are not Excel-friendly and we have several VBA macros to run on the selected sequences.

Thank you for your time,
Linda

Hi there Linda.

We took another look - since it seemed strange we couldn’t reproduce your problem… and realised that there definitely is something wrong when the ‘output to textbox’ selection popup menu option is used (we at first only tested the Alignment window’s File->Output to text box’ option, of course!).

The bug is now fixed in the Jalview development branch … please try it out at http://www.jalview.org/builds/develop/webstart/jalview.jnlp ! If you have any problems don’t hesitate to drop us a line here, or comment directly over at http://issues.jalview.org/browse/JAL-1853

Happy Jalviewing !
Jim.

ps. If you ever feel like upgrading from your VB/Excel solution, then you might be interested in the Groovy interpreter we have embedded in Jalview, which allows you to run scripts directly on the current alignment or selected region.

···

On 01/09/2015 13:30, Mungo Carstairs (Staff) wrote:

Dear Mungo,

Thank you very much for your prompt reply!

Here is the procedure we are using:

  1. Choose “.” as gap symbol in the Preferences

  2. Load an alignment file (either .fa or .aln, the problem was seen in both cases)

  3. Select the desired sequences by mouse left-click on their sequence ID

  4. Mouse right-click on one of the selected sequences → Selection → Output to Textbox… → FASTA

  5. At this point the Alignment Output window opens, where the selected sequences have “-” as gap symbol instead of the requested “.”

While reproducing the error I have realized that the “Output to textbox” command in the “File” drop-down menu does not cause the same problem. In this case “.” was correctly used as a gap symbol, but then all displayed sequences are shown in the output window and not only the selected ones.

You can find our preference file as attachment to this e-mail.

Let me know if you can reproduce the error this time, or if you need more information from our side.

Best Regards,

Linda

.jalview_properties (2.97 KB)

···

2015-09-01 14:30 GMT+02:00 Mungo Carstairs (Staff) <g.m.carstairs@dundee.ac.uk>:

Hello Linda,

Thanks for your enquiry. I have tried to reproduce this behaviour in Jalview 2.8.2 but for me it behaves as it should.

An alignment with dot for gaps is output (to either textbox or file) with dots.

The gap character used is fixed for an alignment at the point where it is created (changing to dot in Preferences won’t affect any open alignments).

If the problem persists, could you please describe the exact steps you are taking, and if possible send your Jalview preferences file?

(This is .jalview_properties which should be in your user home directory.)

Thanks,

Mungo

Mungo Carstairs
Jalview Computational Scientist
The Barton Group
Division of Computational Biology
School of Life Sciences
University of Dundee, Dundee, Scotland, UK.
www.jalview.org
www.compbio.dundee.ac.uk


From: jalview-discuss-bounces@jalview.org <jalview-discuss-bounces@jalview.org> on behalf of Linda Kazandjian <lindak84@gmail.com>
Sent: 01 September 2015 12:10
To: jalview-discuss@jalview.org
Subject: [Jalview-discuss] Gap symbol in alignment output window

Dear Jalview staff,

In our lab we are great fans of your tool, and we have recently upgraded from an old Jalview version to the newest (v. 2.8.2). Unfortunately, though, we found out a new feature which is not ideal for our workflow:

In the old version, when we selected some sequences from an alignment and chose the option “Output to textbox…” the gap symbol used in the “Alignment output” window was matching the symbol selected in the preferences. Therefore, if we chose to display the gaps as dots, we had dots also in the output window. With the new version the gap symbol used in the output window seems to depend only on the format chosen, and not on the symbol selected in the preferences.

On the other hand, if we save the alignment with the “Save as…” button, the gap symbol used is the same one we chose in the “Preferences”.

Here is our question: is there still a way to keep the preferred gap symbol also in the output window? Unfortunately, dashes are not Excel-friendly and we have several VBA macros to run on the selected sequences.

Thank you for your time,
Linda

The University of Dundee is a registered Scottish Charity, No: SC015096

thanks very much Linda ! I thought this was what you were doing :slight_smile:

Let us know if the updated version fixes your problem…
Jim

···

On 01/09/2015 18:12, Linda Kazandjian wrote:

Thank you Jim, it works perfectly in the updated version you have sent! And sorry for not seeing your last answer before sending mine…

One more question: we are used to the InstallAnywhere Jalview version, are you planning to include this bug fix in the next release? And if so, when will this happen?

I will take into consideration your suggestion to switch to the Groovy interpreter…as soon as I understand what this is :slight_smile: I am quite new to Excel VBA too!

All the best,

Linda

···

2015-09-01 19:17 GMT+02:00 Jim Procter <jprocter@compbio.dundee.ac.uk>:

thanks very much Linda ! I thought this was what you were doing :slight_smile:

Let us know if the updated version fixes your problem…
Jim

On 01/09/2015 18:12, Linda Kazandjian wrote:

Dear Mungo,

Thank you very much for your prompt reply!

Here is the procedure we are using:

  1. Choose “.” as gap symbol in the Preferences

  2. Load an alignment file (either .fa or .aln, the problem was seen in both cases)

  3. Select the desired sequences by mouse left-click on their sequence ID

  4. Mouse right-click on one of the selected sequences → Selection → Output to Textbox… → FASTA

  5. At this point the Alignment Output window opens, where the selected sequences have “-” as gap symbol instead of the requested “.”

While reproducing the error I have realized that the “Output to textbox” command in the “File” drop-down menu does not cause the same problem. In this case “.” was correctly used as a gap symbol, but then all displayed sequences are shown in the output window and not only the selected ones.

You can find our preference file as attachment to this e-mail.

Let me know if you can reproduce the error this time, or if you need more information from our side.

Best Regards,

Linda

_______________________________________________
Jalview-discuss mailing list
[Jalview-discuss@jalview.org](mailto:Jalview-discuss@jalview.org)
[http://www.compbio.dundee.ac.uk/mailman/listinfo/jalview-discuss](http://www.compbio.dundee.ac.uk/mailman/listinfo/jalview-discuss)

2015-09-01 14:30 GMT+02:00 Mungo Carstairs (Staff) <g.m.carstairs@dundee.ac.uk>:

Hello Linda,

Thanks for your enquiry. I have tried to reproduce this behaviour in Jalview 2.8.2 but for me it behaves as it should.

An alignment with dot for gaps is output (to either textbox or file) with dots.

The gap character used is fixed for an alignment at the point where it is created (changing to dot in Preferences won’t affect any open alignments).

If the problem persists, could you please describe the exact steps you are taking, and if possible send your Jalview preferences file?

(This is .jalview_properties which should be in your user home directory.)

Thanks,

Mungo

Mungo Carstairs
Jalview Computational Scientist
The Barton Group
Division of Computational Biology
School of Life Sciences
University of Dundee, Dundee, Scotland, UK.
www.jalview.org
www.compbio.dundee.ac.uk


From: jalview-discuss-bounces@jalview.org <jalview-discuss-bounces@jalview.org> on behalf of Linda Kazandjian <lindak84@gmail.com>
Sent: 01 September 2015 12:10
To: jalview-discuss@jalview.org
Subject: [Jalview-discuss] Gap symbol in alignment output window

Dear Jalview staff,

In our lab we are great fans of your tool, and we have recently upgraded from an old Jalview version to the newest (v. 2.8.2). Unfortunately, though, we found out a new feature which is not ideal for our workflow:

In the old version, when we selected some sequences from an alignment and chose the option “Output to textbox…” the gap symbol used in the “Alignment output” window was matching the symbol selected in the preferences. Therefore, if we chose to display the gaps as dots, we had dots also in the output window. With the new version the gap symbol used in the output window seems to depend only on the format chosen, and not on the symbol selected in the preferences.

On the other hand, if we save the alignment with the “Save as…” button, the gap symbol used is the same one we chose in the “Preferences”.

Here is our question: is there still a way to keep the preferred gap symbol also in the output window? Unfortunately, dashes are not Excel-friendly and we have several VBA macros to run on the selected sequences.

Thank you for your time,
Linda

The University of Dundee is a registered Scottish Charity, No: SC015096

Good to hear the patch fixed your problem.

One more question: we are used to the InstallAnywhere Jalview version, are you planning to include this bug fix in the next release? And if so, when will this happen?

An installAnywhere version of the development branch is built at the same time as the webstart version, so you can always download that. Links for each of the builds (versions and type of installation) are available via http://www.jalview.org/development/development-builds

I will take into consideration your suggestion to switch to the Groovy interpreter...as soon as I understand what this is :slight_smile: I am quite new to Excel VBA too!

OK. There's a bit about Groovy scripting in the online help, and there are some very simple groovy scripting examples at
http://www.jalview.org/examples/groovy

Have fun!
Jim

···

On 01/09/2015 19:14, Linda Kazandjian wrote:

Dear Jim, Dear Mungo,

Thank you very much for your assistance and for the information about the Groovy interpreter! I will start playing around with it soon :slight_smile:

Linda

···

2015-09-02 11:15 GMT+02:00 Jim Procter <foreveremain@gmail.com>:

Good to hear the patch fixed your problem.

On 01/09/2015 19:14, Linda Kazandjian wrote:

One more question: we are used to the InstallAnywhere Jalview version,
are you planning to include this bug fix in the next release? And if
so, when will this happen?
An installAnywhere version of the development branch is built at the
same time as the webstart version, so you can always download that.
Links for each of the builds (versions and type of installation) are
available via http://www.jalview.org/development/development-builds
I will take into consideration your suggestion to switch to the Groovy
interpreter…as soon as I understand what this is :slight_smile: I am quite new
to Excel VBA too!
OK. There’s a bit about Groovy scripting in the online help, and there
are some very simple groovy scripting examples at
http://www.jalview.org/examples/groovy

Have fun!
Jim


Jalview-discuss mailing list
Jalview-discuss@jalview.org
http://www.compbio.dundee.ac.uk/mailman/listinfo/jalview-discuss

Hello Natalia - are you using the JalviewLite applet or the desktop version ?

In the desktop version, the File->Export Image option should let you export an EPS or SVG of your alignment view. Both will perfectly reproduce the logo, but you should make sure to tick the 'Lineart' option for rendering text, because some fonts used in Jalview may not render correctly in the SVG or EPS files (you can change the default settings in the Preferences menu).

If the export isn't working then it might be due to a bug. To check if that's the case, enable the Jalview Console (under the Tools Menu), try doing the 'Export Image' operation again and send me any output that appears.

Hear from you soon!
Jim

···

On 24/09/2015 11:19, Requena Sanchez, Natalia (BOTANIK) wrote:

Hi all,

We are trying to export as picture the consensus logo. We have not been able to do it so far and the only way was to make a screen shot which loses resolution.
Any help?

thanks a lot!

Natalia

Prof. Dr. Natalia Requena
Molecular Phytopathology Department
Karlsruhe Institute of Technology
Hertzstrasse 16
D-76187 Karlsruhe
Germany
Tel. +49 (0)721 60844626
  +49 (0)721 60844632 (Secretary)
Fax. +49 (0)721 60844509
natalia.requena@kit.edu
http://www.iab.kit.edu/heisenberg/